aboutsummaryrefslogtreecommitdiff
path: root/example_packages/with_makefile
diff options
context:
space:
mode:
Diffstat (limited to 'example_packages/with_makefile')
-rw-r--r--example_packages/with_makefile/.gitignore1
-rw-r--r--example_packages/with_makefile/Makefile9
-rw-r--r--example_packages/with_makefile/fpm.toml5
-rw-r--r--example_packages/with_makefile/src/hello_makefile.f9010
4 files changed, 25 insertions, 0 deletions
diff --git a/example_packages/with_makefile/.gitignore b/example_packages/with_makefile/.gitignore
new file mode 100644
index 0000000..a007fea
--- /dev/null
+++ b/example_packages/with_makefile/.gitignore
@@ -0,0 +1 @@
+build/*
diff --git a/example_packages/with_makefile/Makefile b/example_packages/with_makefile/Makefile
new file mode 100644
index 0000000..51e72d4
--- /dev/null
+++ b/example_packages/with_makefile/Makefile
@@ -0,0 +1,9 @@
+INCLUDE_FLAGS = $(addprefix -I,$(INCLUDE_DIRS))
+
+$(BUILD_DIR)/libwith_makefile.a: $(BUILD_DIR)/hello_makefile.o
+ ar rs $(@) $(^)
+
+$(BUILD_DIR)/hello_makefile.mod: src/hello_makefile.f90
+
+$(BUILD_DIR)/hello_makefile.o: src/hello_makefile.f90
+ $(FC) -c -J$(BUILD_DIR) $(INCLUDE_FLAGS) $(FFLAGS) -o $(@) $(<)
diff --git a/example_packages/with_makefile/fpm.toml b/example_packages/with_makefile/fpm.toml
new file mode 100644
index 0000000..81dd02a
--- /dev/null
+++ b/example_packages/with_makefile/fpm.toml
@@ -0,0 +1,5 @@
+name = "with_makefile"
+
+[library]
+source-dir = "src"
+build-script = "Makefile"
diff --git a/example_packages/with_makefile/src/hello_makefile.f90 b/example_packages/with_makefile/src/hello_makefile.f90
new file mode 100644
index 0000000..2d4d1a2
--- /dev/null
+++ b/example_packages/with_makefile/src/hello_makefile.f90
@@ -0,0 +1,10 @@
+module hello_makefile
+ implicit none
+ private
+
+ public :: say_hello_from_makefile
+contains
+ subroutine say_hello_from_makefile()
+ print *, "Hello from Makefile library!"
+ end subroutine say_hello_from_makefile
+end module hello_makefile