aboutsummaryrefslogtreecommitdiff
path: root/example_packages/makefile_complex/Makefile
diff options
context:
space:
mode:
authorBrad Richardson <everythingfunctional@protonmail.com>2020-10-26 17:16:44 -0500
committerGitHub <noreply@github.com>2020-10-26 17:16:44 -0500
commit4443986b3d5690ce4ee8bbc348834caa2040be23 (patch)
tree0553b054c43c89edab17a3d6959f7adb84648a61 /example_packages/makefile_complex/Makefile
parente92d9c9c406aff61d404d2afe71c416ed019beb0 (diff)
parent488bdd06ab78cec3085aa86b6dbe36a98f58eb86 (diff)
downloadfpm-4443986b3d5690ce4ee8bbc348834caa2040be23.tar.gz
fpm-4443986b3d5690ce4ee8bbc348834caa2040be23.zip
Merge pull request #213 from everythingfunctional/bootstrap_submodule_support
Bootstrap submodule support
Diffstat (limited to 'example_packages/makefile_complex/Makefile')
-rw-r--r--example_packages/makefile_complex/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/example_packages/makefile_complex/Makefile b/example_packages/makefile_complex/Makefile
new file mode 100644
index 0000000..497c6b2
--- /dev/null
+++ b/example_packages/makefile_complex/Makefile
@@ -0,0 +1,9 @@
+INCLUDE_FLAGS = $(addprefix -I,$(INCLUDE_DIRS))
+
+$(BUILD_DIR)/libmakefile_complex.a: $(BUILD_DIR)/wrapper_mod.o
+ ar rs $(@) $(^)
+
+$(BUILD_DIR)/wrapper_mod.mod: src/wrapper_mod.f90
+
+$(BUILD_DIR)/wrapper_mod.o: src/wrapper_mod.f90
+ $(FC) -c -J$(BUILD_DIR) $(INCLUDE_FLAGS) $(FFLAGS) -o $(@) $(<)