aboutsummaryrefslogtreecommitdiff
path: root/test/example_packages/makefile_complex/Makefile
diff options
context:
space:
mode:
authorBrad Richardson <brichardson@structint.com>2020-06-14 16:52:28 -0700
committerBrad Richardson <brichardson@structint.com>2020-06-14 16:52:28 -0700
commit16daa62ac79573fc87127df6e1ba080f197c5e31 (patch)
tree861b7e21e73111f078f6b2d62618ed1dd539a67e /test/example_packages/makefile_complex/Makefile
parentf97260ef5b5dfe9e2872394a4539090e71e1ceff (diff)
downloadfpm-16daa62ac79573fc87127df6e1ba080f197c5e31.tar.gz
fpm-16daa62ac79573fc87127df6e1ba080f197c5e31.zip
Add support for Makefiles and generic build scripts
Diffstat (limited to 'test/example_packages/makefile_complex/Makefile')
-rw-r--r--test/example_packages/makefile_complex/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/test/example_packages/makefile_complex/Makefile b/test/example_packages/makefile_complex/Makefile
new file mode 100644
index 0000000..497c6b2
--- /dev/null
+++ b/test/example_packages/makefile_complex/Makefile
@@ -0,0 +1,9 @@
+INCLUDE_FLAGS = $(addprefix -I,$(INCLUDE_DIRS))
+
+$(BUILD_DIR)/libmakefile_complex.a: $(BUILD_DIR)/wrapper_mod.o
+ ar rs $(@) $(^)
+
+$(BUILD_DIR)/wrapper_mod.mod: src/wrapper_mod.f90
+
+$(BUILD_DIR)/wrapper_mod.o: src/wrapper_mod.f90
+ $(FC) -c -J$(BUILD_DIR) $(INCLUDE_FLAGS) $(FFLAGS) -o $(@) $(<)