aboutsummaryrefslogtreecommitdiff
path: root/test/example_packages/makefile_complex/src/wrapper_mod.f90
diff options
context:
space:
mode:
authorBrad Richardson <everythingfunctional@protonmail.com>2020-06-15 19:59:58 -0700
committerGitHub <noreply@github.com>2020-06-15 19:59:58 -0700
commit410537bbe21c91a4ec27e45ead99a9f83454c099 (patch)
tree58f186a47143392564cae718abb9017293e5e3d4 /test/example_packages/makefile_complex/src/wrapper_mod.f90
parentf97260ef5b5dfe9e2872394a4539090e71e1ceff (diff)
parentdf531fcffdd5c7b6233d0107152725ce3f8f22c1 (diff)
downloadfpm-410537bbe21c91a4ec27e45ead99a9f83454c099.tar.gz
fpm-410537bbe21c91a4ec27e45ead99a9f83454c099.zip
Merge pull request #99 from everythingfunctional/MakefileSupport
Add support for Makefiles and generic build scripts
Diffstat (limited to 'test/example_packages/makefile_complex/src/wrapper_mod.f90')
-rw-r--r--test/example_packages/makefile_complex/src/wrapper_mod.f9012
1 files changed, 12 insertions, 0 deletions
diff --git a/test/example_packages/makefile_complex/src/wrapper_mod.f90 b/test/example_packages/makefile_complex/src/wrapper_mod.f90
new file mode 100644
index 0000000..e8028b5
--- /dev/null
+++ b/test/example_packages/makefile_complex/src/wrapper_mod.f90
@@ -0,0 +1,12 @@
+module wrapper_mod
+ use hello_makefile, only: say_hello_from_makefile
+
+ implicit none
+ private
+
+ public :: do_stuff
+contains
+ subroutine do_stuff
+ call say_hello_from_makefile
+ end subroutine do_stuff
+end module wrapper_mod