aboutsummaryrefslogtreecommitdiff
path: root/test/example_packages/with_makefile/src
diff options
context:
space:
mode:
authorBrad Richardson <everythingfunctional@protonmail.com>2020-06-15 19:59:58 -0700
committerGitHub <noreply@github.com>2020-06-15 19:59:58 -0700
commit410537bbe21c91a4ec27e45ead99a9f83454c099 (patch)
tree58f186a47143392564cae718abb9017293e5e3d4 /test/example_packages/with_makefile/src
parentf97260ef5b5dfe9e2872394a4539090e71e1ceff (diff)
parentdf531fcffdd5c7b6233d0107152725ce3f8f22c1 (diff)
downloadfpm-410537bbe21c91a4ec27e45ead99a9f83454c099.tar.gz
fpm-410537bbe21c91a4ec27e45ead99a9f83454c099.zip
Merge pull request #99 from everythingfunctional/MakefileSupport
Add support for Makefiles and generic build scripts
Diffstat (limited to 'test/example_packages/with_makefile/src')
-rw-r--r--test/example_packages/with_makefile/src/hello_makefile.f9010
1 files changed, 10 insertions, 0 deletions
diff --git a/test/example_packages/with_makefile/src/hello_makefile.f90 b/test/example_packages/with_makefile/src/hello_makefile.f90
new file mode 100644
index 0000000..2d4d1a2
--- /dev/null
+++ b/test/example_packages/with_makefile/src/hello_makefile.f90
@@ -0,0 +1,10 @@
+module hello_makefile
+ implicit none
+ private
+
+ public :: say_hello_from_makefile
+contains
+ subroutine say_hello_from_makefile()
+ print *, "Hello from Makefile library!"
+ end subroutine say_hello_from_makefile
+end module hello_makefile