aboutsummaryrefslogtreecommitdiff
path: root/example_packages/with_makefile/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'example_packages/with_makefile/Makefile')
-rw-r--r--example_packages/with_makefile/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/example_packages/with_makefile/Makefile b/example_packages/with_makefile/Makefile
new file mode 100644
index 0000000..51e72d4
--- /dev/null
+++ b/example_packages/with_makefile/Makefile
@@ -0,0 +1,9 @@
+INCLUDE_FLAGS = $(addprefix -I,$(INCLUDE_DIRS))
+
+$(BUILD_DIR)/libwith_makefile.a: $(BUILD_DIR)/hello_makefile.o
+ ar rs $(@) $(^)
+
+$(BUILD_DIR)/hello_makefile.mod: src/hello_makefile.f90
+
+$(BUILD_DIR)/hello_makefile.o: src/hello_makefile.f90
+ $(FC) -c -J$(BUILD_DIR) $(INCLUDE_FLAGS) $(FFLAGS) -o $(@) $(<)