aboutsummaryrefslogtreecommitdiff
path: root/test/example_packages/makefile_complex
diff options
context:
space:
mode:
Diffstat (limited to 'test/example_packages/makefile_complex')
-rw-r--r--test/example_packages/makefile_complex/.gitignore1
-rw-r--r--test/example_packages/makefile_complex/Makefile9
-rw-r--r--test/example_packages/makefile_complex/app/main.f907
-rw-r--r--test/example_packages/makefile_complex/fpm.toml8
-rw-r--r--test/example_packages/makefile_complex/src/wrapper_mod.f9012
5 files changed, 37 insertions, 0 deletions
diff --git a/test/example_packages/makefile_complex/.gitignore b/test/example_packages/makefile_complex/.gitignore
new file mode 100644
index 0000000..a007fea
--- /dev/null
+++ b/test/example_packages/makefile_complex/.gitignore
@@ -0,0 +1 @@
+build/*
diff --git a/test/example_packages/makefile_complex/Makefile b/test/example_packages/makefile_complex/Makefile
new file mode 100644
index 0000000..497c6b2
--- /dev/null
+++ b/test/example_packages/makefile_complex/Makefile
@@ -0,0 +1,9 @@
+INCLUDE_FLAGS = $(addprefix -I,$(INCLUDE_DIRS))
+
+$(BUILD_DIR)/libmakefile_complex.a: $(BUILD_DIR)/wrapper_mod.o
+ ar rs $(@) $(^)
+
+$(BUILD_DIR)/wrapper_mod.mod: src/wrapper_mod.f90
+
+$(BUILD_DIR)/wrapper_mod.o: src/wrapper_mod.f90
+ $(FC) -c -J$(BUILD_DIR) $(INCLUDE_FLAGS) $(FFLAGS) -o $(@) $(<)
diff --git a/test/example_packages/makefile_complex/app/main.f90 b/test/example_packages/makefile_complex/app/main.f90
new file mode 100644
index 0000000..ac9ed51
--- /dev/null
+++ b/test/example_packages/makefile_complex/app/main.f90
@@ -0,0 +1,7 @@
+program makefile_complex
+ use wrapper_mod, only: do_stuff
+
+ implicit none
+
+ call do_stuff
+end program makefile_complex
diff --git a/test/example_packages/makefile_complex/fpm.toml b/test/example_packages/makefile_complex/fpm.toml
new file mode 100644
index 0000000..3282cbe
--- /dev/null
+++ b/test/example_packages/makefile_complex/fpm.toml
@@ -0,0 +1,8 @@
+name = "makefile_complex"
+
+[dependencies]
+with_makefile = { path = "../with_makefile" }
+
+[library]
+source-dir = "src"
+build-script = "Makefile"
diff --git a/test/example_packages/makefile_complex/src/wrapper_mod.f90 b/test/example_packages/makefile_complex/src/wrapper_mod.f90
new file mode 100644
index 0000000..e8028b5
--- /dev/null
+++ b/test/example_packages/makefile_complex/src/wrapper_mod.f90
@@ -0,0 +1,12 @@
+module wrapper_mod
+ use hello_makefile, only: say_hello_from_makefile
+
+ implicit none
+ private
+
+ public :: do_stuff
+contains
+ subroutine do_stuff
+ call say_hello_from_makefile
+ end subroutine do_stuff
+end module wrapper_mod