aboutsummaryrefslogtreecommitdiff
path: root/test/example_packages/with_makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/example_packages/with_makefile')
-rw-r--r--test/example_packages/with_makefile/.gitignore1
-rw-r--r--test/example_packages/with_makefile/Makefile9
-rw-r--r--test/example_packages/with_makefile/fpm.toml5
-rw-r--r--test/example_packages/with_makefile/src/hello_makefile.f9010
4 files changed, 0 insertions, 25 deletions
diff --git a/test/example_packages/with_makefile/.gitignore b/test/example_packages/with_makefile/.gitignore
deleted file mode 100644
index a007fea..0000000
--- a/test/example_packages/with_makefile/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/*
diff --git a/test/example_packages/with_makefile/Makefile b/test/example_packages/with_makefile/Makefile
deleted file mode 100644
index 51e72d4..0000000
--- a/test/example_packages/with_makefile/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-INCLUDE_FLAGS = $(addprefix -I,$(INCLUDE_DIRS))
-
-$(BUILD_DIR)/libwith_makefile.a: $(BUILD_DIR)/hello_makefile.o
- ar rs $(@) $(^)
-
-$(BUILD_DIR)/hello_makefile.mod: src/hello_makefile.f90
-
-$(BUILD_DIR)/hello_makefile.o: src/hello_makefile.f90
- $(FC) -c -J$(BUILD_DIR) $(INCLUDE_FLAGS) $(FFLAGS) -o $(@) $(<)
diff --git a/test/example_packages/with_makefile/fpm.toml b/test/example_packages/with_makefile/fpm.toml
deleted file mode 100644
index 81dd02a..0000000
--- a/test/example_packages/with_makefile/fpm.toml
+++ /dev/null
@@ -1,5 +0,0 @@
-name = "with_makefile"
-
-[library]
-source-dir = "src"
-build-script = "Makefile"
diff --git a/test/example_packages/with_makefile/src/hello_makefile.f90 b/test/example_packages/with_makefile/src/hello_makefile.f90
deleted file mode 100644
index 2d4d1a2..0000000
--- a/test/example_packages/with_makefile/src/hello_makefile.f90
+++ /dev/null
@@ -1,10 +0,0 @@
-module hello_makefile
- implicit none
- private
-
- public :: say_hello_from_makefile
-contains
- subroutine say_hello_from_makefile()
- print *, "Hello from Makefile library!"
- end subroutine say_hello_from_makefile
-end module hello_makefile